Results 1 to 3 of 3

Thread: Help sorting dates and dates

  1. #1

    Help sorting dates and dates



    Register for a FREE account, and/
    or Log in to avoid these ads!

    Hello Guys,

    I am new to the forum and just remembering old times with Excel and just started using the latest version (2013).
    I got a database with dates in this format:
    ="month day, year" or
    ="November 21, 2013"


    When filtering, I don't have the option to sort by date, but by "A to Z letters".

    I want to be able to sort this column by dates, but it seems the formatting needs changing.

    I've tried changing by going into format cell > and choosing the date category, but I'm still unable to filter by dates.

    Can you please help me change date formatting without doing it manually? I've already tried with functions, but it doesn't seem to work either.

    Any kind of advice is valuable.

    Thanks a lot!

  2. #2
    Super Moderator p45cal's Avatar
    Join Date
    Dec 2012
    Posts
    1,502
    Articles
    0
    Excel Version
    365
    Convert them to real Excel dates as follows:
    Select the single column of cells containing the dates (not the entire column of the whole sheet).
    In the ribbon, go to the Data tab, and select Text to Columns in the Data Tools section
    Choose delimited in the dialogue box, click Next, untick all the boxes, click Next, in Step 3 chose Date and select MDY in the dropdown, then click Finish.
    Now your text dates are real dates.

  3. #3
    Quote Originally Posted by p45cal View Post
    Convert them to real Excel dates as follows:
    Select the single column of cells containing the dates (not the entire column of the whole sheet).
    In the ribbon, go to the Data tab, and select Text to Columns in the Data Tools section
    Choose delimited in the dialogue box, click Next, untick all the boxes, click Next, in Step 3 chose Date and select MDY in the dropdown, then click Finish.
    Now your text dates are real dates.
    Thanks a lot. It worked in most fields. There were only few rows in which this info was changed into text instead of proper dates, so I had to manually change it. It's all sorted now though. Once again. Thanks!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •