Results 1 to 5 of 5

Thread: Multiple axis labels in the wrong place

  1. #1

    Question Multiple axis labels in the wrong place



    Register for a FREE account, and/
    or Log in to avoid these ads!

    Hi there!

    I have 35 years of daily data and need to present 3 graphs for each year. An example (of 1979) is displayed below. My issue is that for the x axis labels, it's required that the labels sit between the gridlines. I don't know how to adjust it in Excel. From searching what's already out there, it seems people just edit the axis label to fit, but I was hoping for a less manually intensive job for the 105 graphs I have to edit. Also, the end idea is to have all 3 graphs per year in one A3 doc, so they can be read vertically with the date lies matching up between graphs. Therefore, I was hoping that the solution would be linked to the data, so that when they're moved, they don't lose the precise positioning.

    Does anyone know the best way to apply this change?

    Thanks!
    Attached Files Attached Files

  2. #2
    Hello,

    I'm not sure I understand the issue correctly, but if the problem is that your labels are in the middle of your graph you can move them to the bottom. Chart Tools > Layout > Axes > Primary Horizontal Axis > More Primary Horizontal Axis Options > Axis Options > Axis Labels (about halfway down) then change to "Low"

    Hope this helps.

  3. #3
    Acolyte Andy Pope's Avatar
    Join Date
    Mar 2011
    Location
    London, England
    Posts
    39
    Articles
    0
    Excel Version
    2016
    The month appear to the left because only the first day of each month, on the date axis, is displayed.

    You can add a dummy series to the secondary axis, enable secondary horizontal axis
    Secondary vertical axis crosses automatic.

    remove secondary vertical axis formatting
    remove primary horizontal axis labels

    I have left the axes unformatted in one of the charts so you can see how it was done.
    Attached Files Attached Files
    Cheers
    Andy

    www.andypope.info

  4. #4
    Quote Originally Posted by Andy Pope View Post
    The month appear to the left because only the first day of each month, on the date axis, is displayed.

    You can add a dummy series to the secondary axis, enable secondary horizontal axis
    Secondary vertical axis crosses automatic.

    remove secondary vertical axis formatting
    remove primary horizontal axis labels

    I have left the axes unformatted in one of the charts so you can see how it was done.
    Many thanks Andy!

  5. #5
    Hi Andy, (and all interested)

    Be warned, when transferring to word 2013, there is a weird issue: the secondary axis does not display properly unless the primary axis is also displayed - not sure the reason why. My fix was to have the primary axis on but invisible (format the labels to have no outline) as well as the second axis on.

    Tom

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •