Results 1 to 1 of 1

Thread: Can't get table relationship working in the Data Model

  1. #1
    Super Moderator p45cal's Avatar
    Join Date
    Dec 2012
    Posts
    1,935
    Articles
    0
    Excel Version
    365

    Can't get table relationship working in the Data Model



    Register for a FREE account, and/
    or Log in to avoid these ads!

    In the attached Exercise1.xlsx there are two tables each on its own sheet.
    I loaded them both into Power Query, merged/joined them on Part Number/WO# and loaded to a pivot table.
    It works as expected:
    Click image for larger version. 

Name:	2021-05-04_185213.png 
Views:	5 
Size:	21.5 KB 
ID:	10483

    Now I don't want to do that!
    In Exercise1b.xlsx, I'm trying to learn about setting up relations between the tables in the Data Model, so I get both tables into the Data model and create a relationship, ensuring I've got unique values in one table:
    Click image for larger version. 

Name:	2021-05-04_185613.png 
Views:	5 
Size:	18.6 KB 
ID:	10484
    now I try to use that in a pivot table and get:
    Click image for larger version. 

Name:	2021-05-04_185924.png 
Views:	8 
Size:	57.3 KB 
ID:	10485

    Why?!
    The second file is too big to attach so here's a link: https://app.box.com/s/5goymq7qbd5i9lg1peiou75xbyqabptc
    Attached Files Attached Files
    Last edited by p45cal; Yesterday at 07:11 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •