Results 1 to 3 of 3

Thread: Loss of Ribbon/Controls after macro runs

  1. #1
    Acolyte Nick Burns's Avatar
    Join Date
    May 2017
    Posts
    80
    Articles
    0
    Excel Version
    Office 365

    Loss of Ribbon/Controls after macro runs



    Register for a FREE account, and/
    or Log in to avoid these ads!

    I have a macro that simply runs some PowerQueries, saves the sheets/tables to a new file and then closes, leaving open the new file.

    After which the Ribbon is completely blank. I can get it "refreshed" by viewing the Backstage (ALT-F) and then ESCaping back but doing the same in the macro
    SendKeys "%f{ESC}" doesn't help.

    Anyone else run into this issue and know of a way to refresh the Ribbon again?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	MissingRibbon.PNG 
Views:	9 
Size:	9.6 KB 
ID:	9437  
    Oh... by the way, YOU'RE WELCOME!

  2. #2
    Acolyte Nick Burns's Avatar
    Join Date
    May 2017
    Posts
    80
    Articles
    0
    Excel Version
    Office 365
    Anyone? Bueller? Bueller?

    I've even tried the following without luck:

    Code:
        Application.ExecuteExcel4Macro "SHOW.TOOLBAR(""Ribbon"",False)"
        Application.Wait (Now + TimeValue("0:00:05"))
        Application.ExecuteExcel4Macro "SHOW.TOOLBAR(""Ribbon"",true)"


    Oh... by the way, YOU'RE WELCOME!

  3. #3
    Super Moderator Bob Phillips's Avatar
    Join Date
    Mar 2011
    Posts
    1,699
    Articles
    0
    Excel Version
    O365
    Not come across it myself, but try that code in a macro run from OnTime, doesn't need to be more than a seconds timing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •