Results 1 to 3 of 3

Thread: How do I prevent Excel from automatically matching the formats of nearby cells?

  1. #1

    How do I prevent Excel from automatically matching the formats of nearby cells?



    Register for a FREE account, and/
    or Log in to avoid these ads!

    Excel has a really frustrating and unwelcome "feature" where if you enter something into an unformatted cell, it sets the formatting to match nearby cells. Anyone know how to turn this off?

    To illustrate what I'm referring to, here's an example that reproduces the problem:
    1. Create a new workbook.
    2. Enter some text into cells A1, A2, and A3.
    3. Highlight cells A1, A2, and A3, and give them a fill color (yellow, for example)
    4. Now enter some text into cell A4.

    Notice how Excel automatically changed the fill color on A4 to yellow to match the cells above?

    I have a workbook where this sort of thing is happening all the time when I don't want it to, and it's driving me crazy. How can I tell Excel to leave my formatting alone?

    I'm using Excel 2007.

    Thanks.

  2. #2
    Conjurer Roger Govier's Avatar
    Join Date
    Mar 2011
    Location
    Located near Abergavenny, South Wales, UK
    Posts
    113
    Articles
    0
    Hi

    Excel Options> Advanced >Editing options>un-check "Extend data range formats and and formulas"
    Regards

    Roger Govier
    Microsoft Excel MVP
    http://www.technology4u.co.uk

  3. #3

    Thank you

    I knew it had to be simple! I must have looked through that options list a dozen times without noticing that particular option.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •